Problem running GBA

GaryB
Posts: 4
Joined: Thu Sep 23, 2021 7:29 pm
Has thanked: 1 time

Problem running GBA

Unread post by GaryB »

Howdy, I have a problem running the GBA core. I open the menu and select it but then the screen goes black, the red light on my MiSTer flashes a couple of times and 2 to 3 seconds later I am back at the MiSTer menu screen. I have run update_all but still it is the same. Can you please tell me how to fix it?
Thanks
MostroW
Posts: 109
Joined: Tue Aug 18, 2020 3:32 pm
Has thanked: 28 times
Been thanked: 16 times

Re: Problem running GBA

Unread post by MostroW »

stupid question(s) maybe but:

1: do you have the sdram module?
2: if you do, did the core work before?
GaryB
Posts: 4
Joined: Thu Sep 23, 2021 7:29 pm
Has thanked: 1 time

Re: Problem running GBA

Unread post by GaryB »

MostroW wrote: Thu Sep 23, 2021 8:15 pm stupid question(s) maybe but:

1: do you have the sdram module?
2: if you do, did the core work before?

1: yes, 128mb
2: yes it did

I have been playing gba games on it for a couple of weeks but yesterday during the bootup screen, it froze with the blue gameboy text on the screen
and nothing would work, so I reset it. Since then each time I load the gba core it has a black screen for 2-3 secs and then goes back to the MiSTer menu.

I have tried replacing the boot.rom but it's the same. Please help
hooxxx
Posts: 12
Joined: Thu Sep 02, 2021 2:53 pm

Re: Problem running GBA

Unread post by hooxxx »

delete boot.rom and GBA.CFG from /media/fat/config and see if it helps
GaryB
Posts: 4
Joined: Thu Sep 23, 2021 7:29 pm
Has thanked: 1 time

Re: Problem running GBA

Unread post by GaryB »

hooxxx wrote: Fri Sep 24, 2021 10:30 am delete boot.rom and GBA.CFG from /media/fat/config and see if it helps
I deleted the boot.rom but there is no GBA.CFG file in that folder.
Still the same

Edit:- also not sure if it's related but now the gameboy core is not loading either, same thing. goes back to the menu.
hooxxx
Posts: 12
Joined: Thu Sep 02, 2021 2:53 pm

Re: Problem running GBA

Unread post by hooxxx »

GaryB wrote: Fri Sep 24, 2021 11:31 am
hooxxx wrote: Fri Sep 24, 2021 10:30 am delete boot.rom and GBA.CFG from /media/fat/config and see if it helps
I deleted the boot.rom but there is no GBA.CFG file in that folder.
Still the same

Edit:- also not sure if it's related but now the gameboy core is not loading either, same thing. goes back to the menu.
that's weird, there should be a config file in media/fat/config if you used the core before
if you have a spare micro sd card try a clean install with it (sorry but I don't have any more ideas)

how about other cores? no problems there?
MostroW
Posts: 109
Joined: Tue Aug 18, 2020 3:32 pm
Has thanked: 28 times
Been thanked: 16 times

Re: Problem running GBA

Unread post by MostroW »

this is beginning to sound more like sd card corruption, you could try a clean install and see if the problem persists?
FPGAzumSpass
Posts: 119
Joined: Sat May 23, 2020 12:55 pm
Has thanked: 10 times
Been thanked: 97 times

Re: Problem running GBA

Unread post by FPGAzumSpass »

Sounds like the .rbf of the GBA itself is corrupt. You can't even load into the core, right?

Please delete the GBA.rfb and download new or use updater.
GaryB
Posts: 4
Joined: Thu Sep 23, 2021 7:29 pm
Has thanked: 1 time

Re: Problem running GBA

Unread post by GaryB »

FPGAzumSpass wrote: Fri Sep 24, 2021 8:23 pm Sounds like the .rbf of the GBA itself is corrupt. You can't even load into the core, right?

Please delete the GBA.rfb and download new or use updater.
Thank you! that fixed it
Post Reply