Page 1 of 1

Button also registers as D-pad down

Posted: Sat Apr 10, 2021 1:30 am
by stelfAkshun
I'm using an M30 6-button controller wired to an unpowered USB hub. For some reason the C button registers as down. So if I map C to the GBA's A button, it's like I'm pressing down and A at the same time. Even if C isn't mapped to anything, down isn't mapped to anything, or if I only map right and leave everything else undefined, C still registers as down. This is the only core where anything like this happens. I tried deleting the GBA input config and the GBA core config, but that didn't help.

Is this happening to anyone else? Is there some file I missed that could be causing this?

Re: Button also registers as D-pad down

Posted: Sun Apr 11, 2021 6:48 am
by Malan
I use an M30, it works fine with the GBA core. I use D-Input mode with the MiSTer and the default D-Pad option. Maybe you should try?

To switch to D-Input mode, unplug your M30 and make sure it's off, then press and hold Y+START, you should have only the first LED blinking. Then reconnect the controller to the MiSTer.
To set the D-Pad to default, your M30 must be connected first, then press and hold UP+MINUS for at least 5 sec.

After you've done both, you'll need to remap everything in the main menu of the MiSTer, and then again in the GBA core if you want a button custom config.

If it doesn't work, try X-Input mode instead (X+START).

Hope it'll help.

Re: Button also registers as D-pad down

Posted: Sun Apr 11, 2021 4:19 pm
by stelfAkshun
Thanks for the advice. This is a pretty strange problem to have to deal with.
Looking at the manual and 8bitdo's FAQ, it looks like my 2.4g controller doesn't have extra modes (dinput/xinput/Switch/Mac) like the BT version. I did reset the D-pad and the main button config, but still no luck. I think I'll have to settle for avoiding the C button.

Re: Button also registers as D-pad down

Posted: Sun Apr 11, 2021 7:49 pm
by Malan
That's pretty weird indeed... Have you tried to update the firmware of your M30?