Any tips for capturing MiSTer in OBS? Audio out of sync

For topics which do not fit in other specific forums.
Deezdrama
Posts: 47
Joined: Wed Sep 29, 2021 5:28 am
Been thanked: 6 times

Any tips for capturing MiSTer in OBS? Audio out of sync

Unread post by Deezdrama »

So ive exclusively used OBS in the past for screen capturing PC games or Desktop environment but after acquiring my mister Ive decided I wanted to capture some mister gameplay and picked up an EVGA XR1 lite capture card.


First question.... Im running a 2160/4k display and in the past always screen captured at 2160 res and set my output video downscale to 1440 or 1080 depending on the output res I wanted. Well I have my mister set to output 1080p with 5x scaling so in obs i set my base resolution to 1080p and output to 1080p with output quality set to "indistinguishable", and using nvenc encoder (my rtx 3080 is alot better for encoding than my aged 7700k cpu)
Image quality looks good, just wondered if theres any other settings I should consider?


My real problem arrises when it comes to audio. Some cores like NES and NeoGeo have maybe a half a second to 1 sec lagging audio where its out of sync. The genesis core is horrible and about 2-3 seconds behind the video.

I know there was a trick for streamers to go into control panel/sound/recording tab .... then go to properties of the capture card and make sure "listen to device" was checked and to output to speakers, but this has no change for me.
Is such a long audio delay normal?
Why does it vary by core?
Must I manually add an offset for audio for each core to get audio to sync?

Any other tips or suggesstions for capturing my mister in OBS?

Much appreciated!!




EDIT+++++++++
OK, so in davinci resolve studio im able to pull the audio channel back about 1.5 seconds and everything seems to sync pretty well. It wasnt 2-3 seconds like I thought but still pretty bad. Anyway, this is what I will do to address the issue for now unless anyone has a better way?
Stupid Dufus
Posts: 65
Joined: Sun Aug 30, 2020 12:04 am
Has thanked: 20 times
Been thanked: 14 times

Re: Any tips for capturing MiSTer in OBS? Audio out of sync

Unread post by Stupid Dufus »

I've done a bit of a streaming and capturing through OBS and haven't experienced audio issues like you're describing. I just did a quick test with SNES capturing with analog and digital audio (with hdmi audio extractor) and didn't have any lag issues.

Running i7-8700, gtx 1060 6gb. Video capture with Datapath VisionRGB-E1S.

More than happy to try a specific combination if you'd like.
Deezdrama
Posts: 47
Joined: Wed Sep 29, 2021 5:28 am
Been thanked: 6 times

Re: Any tips for capturing MiSTer in OBS? Audio out of sync

Unread post by Deezdrama »

I'm running a 7700k, rtx 3080..... Just uninstalled obs and reinstalled latest version.
Same issues 🙄
I'm not sure if its my capture card, windows settings ,or obs settings I should be looking at.

Nes core is almost perfectly fine
Neo geo audio is probably a half of a second behind.
SNES a little worse
Sega genesis is horrible.

I haven't tested any others.

Using a capture card is new to me, I need to connect some other consoles and see what it does tomorrow.
I just have no idea how to correct it other than in edit.
AngelicLiver
Posts: 21
Joined: Fri May 29, 2020 8:50 am
Has thanked: 2 times
Been thanked: 4 times

Re: Any tips for capturing MiSTer in OBS? Audio out of sync

Unread post by AngelicLiver »

I've had similar issues with a number of USB 3.0 capture devices. YMMV but I found switching to a different USB port using a different controller completely solved the problem, my motherboard had some ports on USB 3.2 gen 2 and regardless of drivers, all my capture devices refused to work on them.

Failing that perhaps try "vsync_adjust=0" in the MiSTer.ini as that is the most compatible of the HDMI video modes?

Ironically having gone through about half-a-dozen expensive capture devices I've settled on a cheap Chinese "Ezcoo" box that's been pretty bulletproof.
Deezdrama
Posts: 47
Joined: Wed Sep 29, 2021 5:28 am
Been thanked: 6 times

Re: Any tips for capturing MiSTer in OBS? Audio out of sync

Unread post by Deezdrama »

AngelicLiver wrote: Thu Oct 21, 2021 9:12 am I've had similar issues with a number of USB 3.0 capture devices. YMMV but I found switching to a different USB port using a different controller completely solved the problem, my motherboard had some ports on USB 3.2 gen 2 and regardless of drivers, all my capture devices refused to work on them.

Failing that perhaps try "vsync_adjust=0" in the MiSTer.ini as that is the most compatible of the HDMI video modes?

Ironically having gone through about half-a-dozen expensive capture devices I've settled on a cheap Chinese "Ezcoo" box that's been pretty bulletproof.
I have a good for nothing USB 3.1 gen 2 port on my motherboard that doesn't seem to work for anything other than a mouse, after reading your comment I hopped out of bed to go look thinking I may of plugged it in to that port by accident..... Nope.
But this made me look at my motherboard manual, and come to find out, the USB port directly above the funky port is also a funky gen 2 port that I thought was a normal USB 3 port and this is where the capture card is plugged into.

I'll swap it around tomorrow and report back.
Thanks!
AngelicLiver
Posts: 21
Joined: Fri May 29, 2020 8:50 am
Has thanked: 2 times
Been thanked: 4 times

Re: Any tips for capturing MiSTer in OBS? Audio out of sync

Unread post by AngelicLiver »

🤞 good luck!
Deezdrama
Posts: 47
Joined: Wed Sep 29, 2021 5:28 am
Been thanked: 6 times

Re: Any tips for capturing MiSTer in OBS? Audio out of sync

Unread post by Deezdrama »

AngelicLiver wrote: Thu Oct 21, 2021 9:12 am I've had similar issues with a number of USB 3.0 capture devices. YMMV but I found switching to a different USB port using a different controller completely solved the problem, my motherboard had some ports on USB 3.2 gen 2 and regardless of drivers, all my capture devices refused to work on them.

Failing that perhaps try "vsync_adjust=0" in the MiSTer.ini as that is the most compatible of the HDMI video modes?

Ironically having gone through about half-a-dozen expensive capture devices I've settled on a cheap Chinese "Ezcoo" box that's been pretty bulletproof.
You would think I would know by now to try a different USB port 🤷‍♂️🤣
Or maybe you'd think by now windows would have these issues ironed out lol.
I changed the USB port and audio is in sync now so thanks for making me check this!

What's weird is I looked again and the problem USB I was using is labeled as USB 3.0 on the io panel but in the manual its labeled as 3.1 gen 2. What I don't understand is it and the one directly next to it that is now working correctly are part of the same USB cluster and you would think are both driven the same but one works and one causes audio issues. There's no damage to the port giving issues either.
Oh well.... Its working now, thanks for the point in the right direction!
Deezdrama
Posts: 47
Joined: Wed Sep 29, 2021 5:28 am
Been thanked: 6 times

Re: Any tips for capturing MiSTer in OBS? Audio out of sync

Unread post by Deezdrama »

AngelicLiver wrote: Thu Oct 21, 2021 9:12 am I've had similar issues with a number of USB 3.0 capture devices. YMMV but I found switching to a different USB port using a different controller completely solved the problem, my motherboard had some ports on USB 3.2 gen 2 and regardless of drivers, all my capture devices refused to work on them.

Failing that perhaps try "vsync_adjust=0" in the MiSTer.ini as that is the most compatible of the HDMI video modes?

Ironically having gone through about half-a-dozen expensive capture devices I've settled on a cheap Chinese "Ezcoo" box that's been pretty bulletproof.
Well I thought changing USB ports fixed it.... Audio is synced at the beginning of recordings but after a couple minutes of recording the audio starts lagging behind. The longer I record the worse it gets.
AngelicLiver
Posts: 21
Joined: Fri May 29, 2020 8:50 am
Has thanked: 2 times
Been thanked: 4 times

Re: Any tips for capturing MiSTer in OBS? Audio out of sync

Unread post by AngelicLiver »

Have you tried setting "vsync_adjust=0" in the MiSTer.ini?
bbond007
Posts: 262
Joined: Tue May 26, 2020 5:06 am
Has thanked: 30 times
Been thanked: 64 times

Re: Any tips for capturing MiSTer in OBS? Audio out of sync

Unread post by bbond007 »

Deezdrama wrote: Fri Oct 22, 2021 2:36 am Well I thought changing USB ports fixed it.... Audio is synced at the beginning of recordings but after a couple minutes of recording the audio starts lagging behind. The longer I record the worse it gets.
I got a USB3 Elgato HD60s that worked very well with OBS on my Ivy Bridge i7 3770 Alienware X51 r1. I later decided that I wanted to instead use the HD60s with an AMD FX 8320 machine with 990FX chipset. It was very laggy and frequently stalled. Nothing like the smooth experienced on the X51.

I tried updating the USB 3.0 drivers and search for other fixes, but despite my best efforts I was never able to get it to work reliably. I ended up getting a PCI-E USB 3.1 card that fixed the problem...
Deezdrama
Posts: 47
Joined: Wed Sep 29, 2021 5:28 am
Been thanked: 6 times

Re: Any tips for capturing MiSTer in OBS? Audio out of sync

Unread post by Deezdrama »

bbond007 wrote: Fri Oct 22, 2021 6:18 pm
Deezdrama wrote: Fri Oct 22, 2021 2:36 am Well I thought changing USB ports fixed it.... Audio is synced at the beginning of recordings but after a couple minutes of recording the audio starts lagging behind. The longer I record the worse it gets.
I got a USB3 Elgato HD60s that worked very well with OBS on my Ivy Bridge i7 3770 Alienware X51 r1. I later decided that I wanted to instead use the HD60s with an AMD FX 8320 machine with 990FX chipset. It was very laggy and frequently stalled. Nothing like the smooth experienced on the X51.

I tried updating the USB 3.0 drivers and search for other fixes, but despite my best efforts I was never able to get it to work reliably. I ended up getting a PCI-E USB 3.1 card that fixed the problem...
I don't know if I have room for another card with this fat 3080 in there 🤦‍♂️
I was hoping it would be something simple like adjust audio bitrate or something but I'm new to capture cards so could be something simple like that or user error, I just don't know at this point 🤦‍♂️🤦‍♂️
Deezdrama
Posts: 47
Joined: Wed Sep 29, 2021 5:28 am
Been thanked: 6 times

Re: Any tips for capturing MiSTer in OBS? Audio out of sync

Unread post by Deezdrama »

AngelicLiver wrote: Fri Oct 22, 2021 8:01 am Have you tried setting "vsync_adjust=0" in the MiSTer.ini?
That's what I've had it set to since I've had my mister.
Maybe I should try 2 (low lag)?

It seems like it would be something else since all audio is since fine at the beginning of a capture but the longer the recording is....the more out of sync audio gets 🤷‍♂️
Deezdrama
Posts: 47
Joined: Wed Sep 29, 2021 5:28 am
Been thanked: 6 times

Re: Any tips for capturing MiSTer in OBS? Audio out of sync

Unread post by Deezdrama »

I thought the audio delay progressed over time since all my captures were fine at the beginning and would get progressivly worse but then I captured 15 min of nes castlevania and the whole video was fine. Suspecting it may have something to do with changing games/cores while recording I made another 15 min capture but changed games and cores every minute or so..... The whole video was about 1 to 2 sec out of sync
Deezdrama
Posts: 47
Joined: Wed Sep 29, 2021 5:28 am
Been thanked: 6 times

Re: Any tips for capturing MiSTer in OBS? Audio out of sync

Unread post by Deezdrama »

Here's a video I did of the xr1 lite.

At the end of the video I have a capture of 5 games from 5 cores, each time I switch cores the audio lags behind progressively.
Any ideas why this is?


...


Post Reply