CIFS error mounting due to Superblock error?

For topics which do not fit in other specific forums.
MouseboyFPGA
Posts: 17
Joined: Mon May 25, 2020 9:04 am
Has thanked: 1 time
Been thanked: 2 times

CIFS error mounting due to Superblock error?

Unread post by MouseboyFPGA »

Hi all, just thought I'd ask the community for advice on something I can't fathom how to resolve. I'm trying to help someone out (remotely) and they're getting an error CIFS mounting "Can't read superblock".

The CIFS file is a copy of a working config I use with their parameters edited in for Server and Share. Here are the things I've checked:
-samba is renamed/enabled on MiSTer
-Guest account is enabled in Windows 10
-NTFS Permissions are Everyone Modify and Authenticated Users Modify
-Share Permissions are Everyone Modify and Authenticated Users Modify
-The Disk being used originally was an NTFS formatted 1tb M2 - I've since tested this with an ExFat VHDX I created (to avoid NTFS permissions issues or any physical 'block' issues
-Have performed a CHKDSK of drives
-Can open MiSTer SD Card from PC \\Mister etc
-Used a different SDCard and built it from scratch (using a working config/process I use succesfully)
-Rebooted both PC and MiSTer at most major test points
-Set a password for Guest (in case blank credentials are an issue - but tried it blank too)
-As an interesting test we put in arbitrary 'Share' details in MiSTer (i.e. a share that doesn't exist on the Win10 PC) and it still came up with the Superblock error which I thought was very curious

If I think of other things we've tested or perform subsequent tests on the advice given I'll update the list accordingly.
Any thoughts guys and gals?
138689370_10159599061408395_6686140409409999541_n.jpg
138689370_10159599061408395_6686140409409999541_n.jpg (23.03 KiB) Viewed 190 times
MouseboyFPGA
Posts: 17
Joined: Mon May 25, 2020 9:04 am
Has thanked: 1 time
Been thanked: 2 times

Re: CIFS error mounting due to Superblock error?

Unread post by MouseboyFPGA »

SOLVED:

Additional checks/changes performed:

-Created a new local user account 'misterpass'
-Added the registry key LocalAccountTokenFilterPolicy and set it to 1
-In Control Panel\Network and Internet\Network and Sharing Centre\Advanced sharing settings, set File sharing Connections to 40-56 bit encryption
-In Control Panel\Network and Internet\Network and Sharing Centre\Advanced sharing settings, set password-protected sharing to 'Turn off password-protected sharing'
-Updated registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\everyoneincludeanonymous from 0 to 1
-Updated registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\restrictnullsessaccess from 1 to 0
Post Reply