Page 1 of 1

Total frustration with update scripts and arcades

Posted: Wed Oct 13, 2021 7:40 pm
by jca
My setup:
Way back I was using "Switch to USB" with my MISTer and did not have any trouble.
Some months ago Sorge said that "Switch to USB" was kind of obsolete and one should use Symlinks which I did. The only directories on /media/fat are Config, linux and Scripts. All other directories are on the USB drive and on /media/fat I have Symlinks to these directories. I did not have trouble.
Recently Sorge made some changes to Symlinks and it seemed that everything was working properly.
More recently was introduced, I tried it once and did not like the idea of the updater downloading stuff behind my back so I still use the old updater in
More more recently an update to Sega System 1 appeared but has not been posted on the official repository so I downloaded it manually from I installed the new core and mras. At this point I noticed that the name of the mras had changed from the official repository and also that I had some roms which were not of the merged kind. They worked with previous versions of the core but not with the latest so I decided to delete all mras and roms related to this core and ran the with mame/hbmame getters. The old mras were downloaded again as their name differ from the mras associated with the new core, which is a nuisance, but mame/hbmame getters did not download anything. Looking at the log they said they could not find any mra in /media/fat/games/mame and /media/fat/games/hbmame. It looks like the Symlinks do not work any longer. As my Symlinks had been created before the modification of Symlinks I deleted them and recreated them but it did not fix the problem. I downloaded and, created 2 ini files update_mame-getter.ini and update_hbmame-getter.ini containing
I ran each getter manually and it worked. Subsequently it also worked when using

When doing the setup for the new Sega System 1 core I noticed that after so many years of using MISTer mras and roms had become a mess: changes in mra names left a bunch of old mras in _Arcade and some old cores were using roms of a type different from merged.
I decided to do a big cleanup: I deleted every single mra and rom from the system, forced a total update by deleting all last_run files.
I ran to get a clean install of the mras and roms but it did not worked as planned:
Not a single alternate mra and not a single Jotego mra was downloaded and subsequently not a single rom for these mras.
For alternate mras I have no idea what to do.
For Jotego mras I know he has a script to do it but on his Github there are 2 scripts and I have no idea which one I should use and even if I knew there is absolutely no information concerning an ini file.

So I am stuck with a system with no alternate and Jotego Arcades.
Any help would be highly appreciated.