MiSTer IO Board doesn't fit DE-10

chaosbuddy
Posts: 3
Joined: Mon May 03, 2021 11:22 pm
Has thanked: 4 times

MiSTer IO Board doesn't fit DE-10

Unread post by chaosbuddy »

Hello all,

Just received my MiSTer Analog IO unit and it doesn't seem to fit neatly into the slots. It's at an angle.

I think it's due to this plastic between the connectors, but I don't know if it's the fault of the person I bought it from (on Amazon), or if it's supposed to be like this. Every image and video I see regarding the MiSTer shows the IO board resting neatly on top of the Ethernet port with no space between.
User avatar
WiteWulf
Posts: 31
Joined: Tue Feb 09, 2021 3:09 pm
Has thanked: 8 times
Been thanked: 9 times

Re: MiSTer IO Board doesn't fit DE-10

Unread post by WiteWulf »

It would be helpful if you could post some pictures of your MiSTer and IO Board.
Nemesis2k
Posts: 4
Joined: Mon May 03, 2021 2:55 pm
Has thanked: 3 times
Been thanked: 1 time

Re: MiSTer IO Board doesn't fit DE-10

Unread post by Nemesis2k »

There could be a blockage in the ports, maybe a bent pin. Need pics to know more.
chaosbuddy
Posts: 3
Joined: Mon May 03, 2021 11:22 pm
Has thanked: 4 times

Re: MiSTer IO Board doesn't fit DE-10

Unread post by chaosbuddy »

That's so weird, I included them in the original post.

Here's the link:

https://photos.app.goo.gl/98ND5HzRvbwPzue96
grizzly
Posts: 160
Joined: Tue Jun 16, 2020 12:22 pm
Has thanked: 15 times
Been thanked: 14 times

Re: MiSTer IO Board doesn't fit DE-10

Unread post by grizzly »

On mine there is quite a bit of force needed to seat the ioboard all the way, so could be that too.
JaguarLV
Posts: 26
Joined: Mon May 25, 2020 12:39 am
Been thanked: 19 times

Re: MiSTer IO Board doesn't fit DE-10

Unread post by JaguarLV »

Looks like the plastic base of the pin header for the Arduino connections are the problem. You can try to carefully remove them.
Attachments
MiSTer-FPGA-IO-Board.png
MiSTer-FPGA-IO-Board.png (904.3 KiB) Viewed 290 times
chaosbuddy
Posts: 3
Joined: Mon May 03, 2021 11:22 pm
Has thanked: 4 times

Re: MiSTer IO Board doesn't fit DE-10

Unread post by chaosbuddy »

JaguarLV wrote: Tue May 04, 2021 6:35 pm Looks like the plastic base of the pin header for the Arduino connections are the problem. You can try to carefully remove them.
Is that plastic base of the pin header standard? I tried a tiny bit and I think it might be glued.
User avatar
WiteWulf
Posts: 31
Joined: Tue Feb 09, 2021 3:09 pm
Has thanked: 8 times
Been thanked: 9 times

Re: MiSTer IO Board doesn't fit DE-10

Unread post by WiteWulf »

Yeah, that plastic header definitely shouldn't be there on the IO board. It's standard for it to be there on pin headers that buy for building kit yourself, but shouldn't be there on a MiSTer IO board.

Does it work as it is? If so I'd be tempted to add some spacers between the brass stand offs and the IO board to give it some extra support and leave it as it is. The only problem with this could be that it may not fit in a case due to the extra height.

Otherwise I think you'll be wanting to either try to carefully remove that header, or else request a refund from the seller for goods not fit for purpose.
User avatar
Nat
Posts: 78
Joined: Sun May 24, 2020 7:28 pm
Location: United Kingdom
Been thanked: 29 times
Contact:

Re: MiSTer IO Board doesn't fit DE-10

Unread post by Nat »

The IO board should most certainly should not be built like this, it is easily fixed though.

The black plastic strip is just friction fit on the pins, best bet is to gently slide them down, while working your way along each pin, applying pressure to push the plastic part down till it falls off the end of the pins, a thin blade would be good for this.
MiSTer FPGA Add-On Boards : UK based, low cost worldwide shipping.
https://MiSTerFPGA.co.uk/
Post Reply