8bitdo M30 Bluetooth controllers no longer work after 20200908 linux update

Discussion of keyboards, gamepads, joysticks and other input related peripherals.
User avatar
keith.f.kelly
Posts: 63
Joined: Sun May 24, 2020 11:10 pm
Location: Sammamish, WA, USA
Contact:

8bitdo M30 Bluetooth controllers no longer work after 20200908 linux update

Unread post by keith.f.kelly »

I can pair the controller fine, but the OSD refuses to recognize any buttons I press on it. I can’t even remap the buttons because when the remapping sequence asks me to press DPad-right, and I do, it acts as if I’m not.

Same problem with my other identical controller.

See https://github.com/MiSTer-devel/Linux-K ... /issues/15
d.ti
Posts: 3
Joined: Tue May 26, 2020 3:35 pm

Re: 8bitdo M30 Bluetooth controllers no longer work after 20200908 linux update

Unread post by d.ti »

I've just tested it (OSD / Genesis Core with 2 player Sonic 2) with my both M30 BT controllers and latest updates. No issues on my side.
Jellybelly
Posts: 2
Joined: Sun Jun 07, 2020 2:48 pm

Re: 8bitdo M30 Bluetooth controllers no longer work after 20200908 linux update

Unread post by Jellybelly »

(sorry a lurker here) Had the same problem last night after the update (but I'm on a generic BT dingle) , had to change the controller (SF30 Pro) allocation to "windows mode" (start + x on controller power up) then re-pair to Mister, now works fine
User avatar
keith.f.kelly
Posts: 63
Joined: Sun May 24, 2020 11:10 pm
Location: Sammamish, WA, USA
Contact:

Re: 8bitdo M30 Bluetooth controllers no longer work after 20200908 linux update

Unread post by keith.f.kelly »

Mine is already on “Windows” mode, and already has the dpad mapped to the dpad (rather than to left or right analog sticks).
Jellybelly
Posts: 2
Joined: Sun Jun 07, 2020 2:48 pm

Re: 8bitdo M30 Bluetooth controllers no longer work after 20200908 linux update

Unread post by Jellybelly »

Have you tried rerunning the pairing script? (wipe any known devices) My Bluetooth naming allocation changed from running it,now seen as sf30pro rather than a non discript joypad name (plus a rumble from pad when paired) when it recognised my pad again
User avatar
keith.f.kelly
Posts: 63
Joined: Sun May 24, 2020 11:10 pm
Location: Sammamish, WA, USA
Contact:

Re: 8bitdo M30 Bluetooth controllers no longer work after 20200908 linux update

Unread post by keith.f.kelly »

Yes. As I said, they pair just fine — but inputs are not recognized.

I’ve already identified that rolling back to the 20200618 Linux kernel image resolves the issue, so this looks like a regression therein.
User avatar
Sorgelig
Site Admin
Posts: 454
Joined: Thu May 21, 2020 9:49 pm
Been thanked: 4 times

Re: 8bitdo M30 Bluetooth controllers no longer work after 20200908 linux update

Unread post by Sorgelig »

Don't use "Switch" mode in 8bitdo controllers. It seems it has some compatibility problem with new kernel driver.
Use X-Input or D-Input mode. My M30 BT works ok in these modes using generic BT receiver.
User avatar
keith.f.kelly
Posts: 63
Joined: Sun May 24, 2020 11:10 pm
Location: Sammamish, WA, USA
Contact:

Re: 8bitdo M30 Bluetooth controllers no longer work after 20200908 linux update

Unread post by keith.f.kelly »

I reset both of my M30 controllers and repaired them in X-Input mode, and that resolved the issue. Thanks!
Dex
Posts: 1
Joined: Sat Sep 05, 2020 10:34 am

Re: 8bitdo M30 Bluetooth controllers no longer work after 20200908 linux update

Unread post by Dex »

after the update button mapping is broken for me too.

8BitDo Wireless USB adapter and DS4 controller - pairing works but no assignment of the buttons.
antibolo
Posts: 47
Joined: Mon Jun 08, 2020 9:49 pm

Re: 8bitdo M30 Bluetooth controllers no longer work after 20200908 linux update

Unread post by antibolo »

Using the 8bitdo dongle, I had to redefine buttons after this update. Seems it's no longer recognized as the same internal ID??
User avatar
laserdisc
Posts: 3
Joined: Mon May 25, 2020 5:04 am

Re: 8bitdo M30 Bluetooth controllers no longer work after 20200908 linux update

Unread post by laserdisc »

I was having a similar issue post 20200908 linux update with my M30 as well and my fix was powering up the DE10 without a network connection (Wifi or cabled). When I need network I just plug it in afterwards and it's fine, problem only occurs at power up if the network cable or WiFi dongle is connected. Weird. I didn't think about it and figured its some 8bitdo firmware issue until I was browsing the forums and found this post.
Sefirosu
Posts: 3
Joined: Sat May 30, 2020 3:58 pm

Re: 8bitdo M30 Bluetooth controllers no longer work after 20200908 linux update

Unread post by Sefirosu »

Having the same issues and the above fixes don’t seem to work. Using an 8bitdo orange USB receiver and 8bitdo SNES type pad.

This shows up repeatedly in the logs:

[ 295.938510] usb 1-1.1: new full-speed USB device number 82 using dwc2
[ 296.027990] usb 1-1.1: New USB device found, idVendor=057e, idProduct=2009, bcdDevice= 2.00
[ 296.028002] usb 1-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 296.028009] usb 1-1.1: Product: Pro Controller
[ 296.028016] usb 1-1.1: Manufacturer: Nintendo Co., Ltd.
[ 296.028023] usb 1-1.1: SerialNumber: 000000000001
[ 296.033371] HID usage: 0x00010004, original interval: 4
[ 296.033382] JS: endpoint->bInterval=4, interval=4
[ 296.033387] HID usage: 0x00010004, applied interval: 4
[ 296.033392] HID usage: 0x00010004, original interval: 8
[ 296.033396] JS: endpoint->bInterval=8, interval=8
[ 296.033400] HID usage: 0x00010004, applied interval: 8
[ 296.034183] nintendo 0003:057E:2009.00CF: hidraw2: USB HID v81.11 Joystick [Nintendo Co., Ltd. Pro Controller] on usb-ffb40000.usb-1.1/input0
[ 297.132538] nintendo 0003:057E:2009.00CF: Failed to set baudrate; ret=-71
[ 297.140318] nintendo 0003:057E:2009.00CF: probe - fail = -71
[ 297.146074] nintendo: probe of 0003:057E:2009.00CF failed with error -71

Any ideas ?
Sefirosu
Posts: 3
Joined: Sat May 30, 2020 3:58 pm

Re: 8bitdo M30 Bluetooth controllers no longer work after 20200908 linux update

Unread post by Sefirosu »

Sefirosu wrote: Sat Sep 26, 2020 8:27 pm Having the same issues and the above fixes don’t seem to work. Using an 8bitdo orange USB receiver and 8bitdo SNES type pad.

This shows up repeatedly in the logs:

[ 295.938510] usb 1-1.1: new full-speed USB device number 82 using dwc2
[ 296.027990] usb 1-1.1: New USB device found, idVendor=057e, idProduct=2009, bcdDevice= 2.00
[ 296.028002] usb 1-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 296.028009] usb 1-1.1: Product: Pro Controller
[ 296.028016] usb 1-1.1: Manufacturer: Nintendo Co., Ltd.
[ 296.028023] usb 1-1.1: SerialNumber: 000000000001
[ 296.033371] HID usage: 0x00010004, original interval: 4
[ 296.033382] JS: endpoint->bInterval=4, interval=4
[ 296.033387] HID usage: 0x00010004, applied interval: 4
[ 296.033392] HID usage: 0x00010004, original interval: 8
[ 296.033396] JS: endpoint->bInterval=8, interval=8
[ 296.033400] HID usage: 0x00010004, applied interval: 8
[ 296.034183] nintendo 0003:057E:2009.00CF: hidraw2: USB HID v81.11 Joystick [Nintendo Co., Ltd. Pro Controller] on usb-ffb40000.usb-1.1/input0
[ 297.132538] nintendo 0003:057E:2009.00CF: Failed to set baudrate; ret=-71
[ 297.140318] nintendo 0003:057E:2009.00CF: probe - fail = -71
[ 297.146074] nintendo: probe of 0003:057E:2009.00CF failed with error -71

Any ideas ?
Downgrading Linux fixes the issue.
paulbnl
Posts: 54
Joined: Sun May 24, 2020 8:48 pm
Has thanked: 1 time
Been thanked: 6 times

Re: 8bitdo M30 Bluetooth controllers no longer work after 20200908 linux update

Unread post by paulbnl »

Sefirosu wrote: Sat Sep 26, 2020 8:27 pm [ 296.028009] usb 1-1.1: Product: Pro Controller
[ 296.028016] usb 1-1.1: Manufacturer: Nintendo Co., Ltd.
Any ideas ?
Looks like your controller/receiver is in Switch mode. You need to change it to Dinput.
User avatar
laserdisc
Posts: 3
Joined: Mon May 25, 2020 5:04 am

Re: 8bitdo M30 Bluetooth controllers no longer work after 20200908 linux update

Unread post by laserdisc »

In my previous post I reported having issues /w the orange 8bitdo BT adapter after the last update where as I had to disconnect the network for the DE10 to detect the controller even though the controller and adapter were sync'd. For reference I used the 8BitDo controller on d-input mode. I recently purchased a Onvian branded so called CSR 4.0 (CSR8510?) bluetooth adapter from a local shop and it works great. All weirdness went away. I don't feel any lag difference which is to say any change isn't detectable by me. The only thing that annoys me is the blinking blue led on the unit while its connected.
TL:DR Lose the orange dongle and give a $10 USB BT Adapter with a CSR8510 chipset a try.
Sefirosu
Posts: 3
Joined: Sat May 30, 2020 3:58 pm

Re: 8bitdo M30 Bluetooth controllers no longer work after 20200908 linux update

Unread post by Sefirosu »

paulbnl wrote: Tue Sep 29, 2020 8:24 am
Sefirosu wrote: Sat Sep 26, 2020 8:27 pm [ 296.028009] usb 1-1.1: Product: Pro Controller
[ 296.028016] usb 1-1.1: Manufacturer: Nintendo Co., Ltd.
Any ideas ?
Looks like your controller/receiver is in Switch mode. You need to change it to Dinput.
I thought I had tried that but from what I’m reading on 8bitdo’s website this probably didn’t work. There are also updates to the dongle and controller firmware, I’ll give all of that a shot when I have a minute.
User avatar
redsteakraw
Posts: 65
Joined: Sun May 24, 2020 11:19 pm
Been thanked: 1 time

Re: 8bitdo M30 Bluetooth controllers no longer work after 20200908 linux update

Unread post by redsteakraw »

keith.f.kelly wrote: Wed Sep 09, 2020 12:36 am I can pair the controller fine, but the OSD refuses to recognize any buttons I press on it. I can’t even remap the buttons because when the remapping sequence asks me to press DPad-right, and I do, it acts as if I’m not.

Same problem with my other identical controller.

See https://github.com/MiSTer-devel/Linux-K ... /issues/15
First off I have the same problem also but I am hooking it up wired mode. I think it is some issue between the Hub board v2.1 and the 8-bitdo controllers. It was working with my external hub and there is a reddit user that had the same issue but with the wireless adapter on the hub board v2.1 also.

https://www.reddit.com/r/fpgagaming/com ... th_8bitdo/

Are you using the USB hub addon board v2.1 also? Do you notice the LED on the port it is plugged in blink and not stay solid like other devices?
Fear is the mind killer!
User avatar
redsteakraw
Posts: 65
Joined: Sun May 24, 2020 11:19 pm
Been thanked: 1 time

Re: 8bitdo M30 Bluetooth controllers no longer work after 20200908 linux update

Unread post by redsteakraw »

I opened an official bug report on my issue you can find it here

https://github.com/MiSTer-devel/Main_MiSTer/issues/297
Fear is the mind killer!
Post Reply