MiSTer with LLAPI/LLOAD flickering inputs

Discussion of keyboards, gamepads, joysticks and other input related peripherals.
sk8er000
Posts: 25
Joined: Fri Oct 01, 2021 2:31 pm
Has thanked: 8 times

MiSTer with LLAPI/LLOAD flickering inputs

Unread post by sk8er000 »

Hello,
I'm pretty new to the MiSTer project but it seems a very interesting solution to play most of the games I've always liked.
I've bought a second hand Mister that came with a LLAPI/LLOAD device and some adapters (DB15 to various controllers), a USB male/male cable and 2 USB/mini USB cables.

From myy understanding I have to plug the 2 USB/mini USB cables to the mister USB hub and to the 2 mini USB ports on th LLAPI/LLOAD device, then the USB 3.0 cable on the serial port of the I/O MiSTer board and to the other usb 3.0 like port on the LLAPI/LLOAD device (I know that it's not a USB 3.0 port but serial ports that uses the same connectors).

Then if I start the LLAPI cores and active on the relative core menu the LLAPI protocol, when I try to play the game if I try to keep pressed a button it's registered like if it is pressed very quicly and not keep pressed like I'm doing.

If I try to use the device without the serial cable the input are registered corrected.
I asked to the previous owner and he said that he never used the serial port but only regular USB to play the games.

Am I missing something or is there something broken?

thank you in advance, here a pic of the LLAPI device:

BIFmKqG.jpg
BIFmKqG.jpg (33.64 KiB) Viewed 293 times
grizzly
Posts: 240
Joined: Tue Jun 16, 2020 12:22 pm
Has thanked: 25 times
Been thanked: 29 times

Re: MiSTer with LLAPI/LLOAD flickering inputs

Unread post by grizzly »

sk8er000 wrote: Fri Oct 01, 2021 2:55 pm he said that he never used the serial port but only regular USB to play the games.
Totally not the reason for selling, nope not at all!

i have never seen anything like that but the picture are way to bad to read anything on the boards so can not look for what it is there.
So better pics or write down all the text on the boards.

One thing you could try is unplug the usb board/hub and run this thing directly on the usb port from the mister, like the blisster is used.
And then the blisster have its own usb port so a regular hub is not needed.
i have no idé if a usbhub before the blisster or this thing can cause problems but it would not surprise me that much if it did.

One other thing.
What power supply do you use for everything?
The one that comes with the de-10 nano is on the weak side and can cause strange problems, for example maybe the power is enough for fast button presses but not for a long one?
sk8er000
Posts: 25
Joined: Fri Oct 01, 2021 2:31 pm
Has thanked: 8 times

Re: MiSTer with LLAPI/LLOAD flickering inputs

Unread post by sk8er000 »

I'm sorry for the bad quality of the picture but I used a trimmed one since I'm not at home today. Tomorrow I'll make a better photo!
Actually I'm using a PSU I already had at home is 5V 4A, I never used the original one because I read that is too weak to power everything, especially if you use an external HDD
sk8er000
Posts: 25
Joined: Fri Oct 01, 2021 2:31 pm
Has thanked: 8 times

Re: MiSTer with LLAPI/LLOAD flickering inputs

Unread post by sk8er000 »

here is a better quality photo:

ktc5yMt.jpeg
ktc5yMt.jpeg (107.91 KiB) Viewed 290 times
User avatar
bootsector
Posts: 139
Joined: Sun May 24, 2020 6:58 pm
Has thanked: 3 times
Been thanked: 20 times

Re: MiSTer with LLAPI/LLOAD flickering inputs

Unread post by bootsector »

LLAPI needs good quality USB 3.0 cable. Shorter the cable is, the better. Try with a different/shorter USB 3.0 cable.
sk8er000
Posts: 25
Joined: Fri Oct 01, 2021 2:31 pm
Has thanked: 8 times

Re: MiSTer with LLAPI/LLOAD flickering inputs

Unread post by sk8er000 »

I'll buy one the shortest I can find on Amazon, and I'll try, thank you, I've tried with this:

ozBR1oz.jpeg
ozBR1oz.jpeg (1.36 MiB) Viewed 288 times
User avatar
bootsector
Posts: 139
Joined: Sun May 24, 2020 6:58 pm
Has thanked: 3 times
Been thanked: 20 times

Re: MiSTer with LLAPI/LLOAD flickering inputs

Unread post by bootsector »

sk8er000 wrote: Sat Oct 02, 2021 10:01 am I'll buy one the shortest I can find on Amazon, and I'll try, thank you, I've tried with this:
This one from the picture is the one I use without issues. But mileage may vary depending on your IO board, etc. I would also suggest powering the second player port by connecting it to MiSTer via USB as well. It could be a good idea to test your user IO port by trying SNAC as well (Sega Genesis, since it uses more pins, that could be tested).
sk8er000
Posts: 25
Joined: Fri Oct 01, 2021 2:31 pm
Has thanked: 8 times

Re: MiSTer with LLAPI/LLOAD flickering inputs

Unread post by sk8er000 »

I just remembered that I have a very short USB 3 cable lying around:

8SOd793.jpeg
8SOd793.jpeg (1.36 MiB) Viewed 286 times

Using this the inputs seems fine but I noticed that if I use the llapi core with llapi serial option set, but I connect the controller without the usb3 cable on the serial ports it just works anyway.
Now I have the doubt that the shorter USB 3 cable isn't simply working but is like if not connected, is there a way to see if the serial port is really communicating with the llapi input device?
User avatar
bootsector
Posts: 139
Joined: Sun May 24, 2020 6:58 pm
Has thanked: 3 times
Been thanked: 20 times

Re: MiSTer with LLAPI/LLOAD flickering inputs

Unread post by bootsector »

I could be wrong, but I think in-core input mapping works only for USB, not LLAPI. So if you map inputs in there but those don't change anything in-game, inputs are coming from LLAPI and not USB. Let us know.
sk8er000
Posts: 25
Joined: Fri Oct 01, 2021 2:31 pm
Has thanked: 8 times

Re: MiSTer with LLAPI/LLOAD flickering inputs

Unread post by sk8er000 »

That's a great idea!
I've started the genesis LLAPI core, selected serial:LLAPI and mapped the input totally wrong (like mapping a, b, c on the directional buttons and directions on a, b, c).
After that I run a pad test ROM and tried some inputs.
If the serial il set to LLAPI the inputs are still the right ones. If I set the serial to OFF the inputs become wrong (as I mapped them).
So this mean the the serial il communicating with the llapi input device and that the issue was the blue USB 3.0 cable!

Thank you very much for your help!
User avatar
bootsector
Posts: 139
Joined: Sun May 24, 2020 6:58 pm
Has thanked: 3 times
Been thanked: 20 times

Re: MiSTer with LLAPI/LLOAD flickering inputs

Unread post by bootsector »

Awesome! Glad I could help. Happy gaming! :)
sk8er000
Posts: 25
Joined: Fri Oct 01, 2021 2:31 pm
Has thanked: 8 times

Re: MiSTer with LLAPI/LLOAD flickering inputs

Unread post by sk8er000 »

I've got a little update.
The cable provided with the LLAPI device was not defective!

Looking at the schemes of my I/O board v 5.5 and comparing them with the 6.1 I've noticed that on the serial area there is one more signal (IO6) selectable with a jumper and some pull up arrays for each signal of the serial port.

So I decided to try to add IO6 to the serial port and a resistor for each signal as intended in the later revisions.

(It's not meant to be pretty :oops: )

9xtD1tV.jpeg
9xtD1tV.jpeg (1.19 MiB) Viewed 280 times

Now using the longer blue USB 3.0 cable the signals aren't flickering anymore like with the shorter cable.

Now I'm just curious to know if this LLAPI device uses IO6 from the serial. I've read that is mainly used for 6 buttons mega drive controller but it was working before (and it's still working now) even if IO6 wasn't connected to the serial port :|
User avatar
bootsector
Posts: 139
Joined: Sun May 24, 2020 6:58 pm
Has thanked: 3 times
Been thanked: 20 times

Re: MiSTer with LLAPI/LLOAD flickering inputs

Unread post by bootsector »

IO6 is not used by LLAPI. The reason it works with the longer cable now is probably because of the added 10k pullups. LLAMA adapter provides 10K pullups on those lines already, so when you added another 10K pullups in parallel, those make them 5K pullups. Stronger pullups now, which might have helped with the signal stabilization.
sk8er000
Posts: 25
Joined: Fri Oct 01, 2021 2:31 pm
Has thanked: 8 times

Re: MiSTer with LLAPI/LLOAD flickering inputs

Unread post by sk8er000 »

Thank you for clarifying!
I was pretty sure, once I saw that it was working with a shorter cable that the problem was on my I/O board.
I find this LLAMA adapter to be very functional I only wish that the db15 port supported a 6 buttons arcade stick but I think that is impossible since there aren't any low lag adapter for that
User avatar
bootsector
Posts: 139
Joined: Sun May 24, 2020 6:58 pm
Has thanked: 3 times
Been thanked: 20 times

Re: Mister with LLAPI/LLOAD flickering inputs

Unread post by bootsector »

sk8er000 wrote: Tue Oct 12, 2021 10:22 am Thank you for clarifying!
I was pretty sure, once I saw that it was working with a shorter cable that the problem was on my I/O board.
I find this LLAMA adapter to be very functional I only wish that the db15 port supported a 6 buttons arcade stick but I think that is impossible since there aren't any low lag adapter for that
I think I've made an adapter that presents itself to the LLAMA as a SNES pad but it gives you a male DB15 port compatible with DB15 6b arcade controllers.
sk8er000
Posts: 25
Joined: Fri Oct 01, 2021 2:31 pm
Has thanked: 8 times

Re: MiSTer with LLAPI/LLOAD flickering inputs

Unread post by sk8er000 »

Is there a link to buy or a scheme to refer?
User avatar
bootsector
Posts: 139
Joined: Sun May 24, 2020 6:58 pm
Has thanked: 3 times
Been thanked: 20 times

Re: MiSTer with LLAPI/LLOAD flickering inputs

Unread post by bootsector »

Schematics attached.
Attachments
supergun_module.png
supergun_module.png (94.84 KiB) Viewed 316 times
sk8er000
Posts: 25
Joined: Fri Oct 01, 2021 2:31 pm
Has thanked: 8 times

Re: MiSTer with LLAPI/LLOAD flickering inputs

Unread post by sk8er000 »

Great I'll try for sure thank you very much!
sk8er000
Posts: 25
Joined: Fri Oct 01, 2021 2:31 pm
Has thanked: 8 times

Re: MiSTer with LLAPI/LLOAD flickering inputs

Unread post by sk8er000 »

Sorry for bothering again..
I was looking at the scheme with a friend to make 2 PCBs for LLAMA but I don't understand what D7 D6 D5 and D4 stand for, what's their meaning?
They aren't connected to any db15 port, right?
User avatar
bootsector
Posts: 139
Joined: Sun May 24, 2020 6:58 pm
Has thanked: 3 times
Been thanked: 20 times

Re: MiSTer with LLAPI/LLOAD flickering inputs

Unread post by bootsector »

Right. Those 4 IC pins are just connected to the pullups, and nothing else.
sk8er000
Posts: 25
Joined: Fri Oct 01, 2021 2:31 pm
Has thanked: 8 times

Re: MiSTer with LLAPI/LLOAD flickering inputs

Unread post by sk8er000 »

Thank you again! We can now try to make a couple of PCBs for LLAMA!
Post Reply