Analog IO Board Color Issue

d21dan
Posts: 2
Joined: Fri Apr 02, 2021 4:56 am

Analog IO Board Color Issue

Unread post by d21dan »

I have noticed an issue with my analog IO Board when outputting to my CRT using component video(same issue when connected to an LCD using component out)

If you look at the captures below are my Mister Street Fighter 2 World Warrior compared to the arcade board hooked up with super gun both connected to the same CRT using component input. The colors seem to be slightly off. To verify this I put both the Mister Core and the Arcade board in test mode. As you can see from the captures below. You can see some blue hue on the dark red and dark green bars.

This is Street Fighter 2 Champion Edition Arcade in test mode
E10C12F1-69EE-4A32-8F73-F024C7ECB800.jpeg
E10C12F1-69EE-4A32-8F73-F024C7ECB800.jpeg (2.2 MiB) Viewed 617 times
This is the same game but running the Mister Core
FE0F6792-5290-4CB0-8E8E-948025F1378D.jpeg
FE0F6792-5290-4CB0-8E8E-948025F1378D.jpeg (2.47 MiB) Viewed 617 times
Below is the capture of the title screen again from SF2CE arcade board
CA8706DB-349C-48BF-B45A-01CE4451F9CB.jpeg
CA8706DB-349C-48BF-B45A-01CE4451F9CB.jpeg (3.22 MiB) Viewed 617 times
FBC2C8FC-91EE-413B-AE4A-1B330ADFBF80.jpeg
FBC2C8FC-91EE-413B-AE4A-1B330ADFBF80.jpeg (3.65 MiB) Viewed 617 times
This is the same capture from the Mister core for comparison
BAE135AD-18E2-4055-AA93-109DE8F1EA72.jpeg
BAE135AD-18E2-4055-AA93-109DE8F1EA72.jpeg (3.35 MiB) Viewed 617 times
F38FF65B-9C8E-4991-8A84-36DBB26965A0.jpeg
F38FF65B-9C8E-4991-8A84-36DBB26965A0.jpeg (2.9 MiB) Viewed 617 times
Also, I tried running the same core outputting on HDMI and there are no color issues the colors look correct when outputting through HDMI. I would like to know if anyone else has tried running the same test and if they have different results than mine. It could be that I have a faulty IO board but I’m unable to confirm. If anyone has the component out IO board and can post the results would be of great help.
Nemesis2k
Posts: 18
Joined: Mon May 03, 2021 2:55 pm
Has thanked: 13 times
Been thanked: 7 times

Re: Analog IO Board Color Issue

Unread post by Nemesis2k »

Ive seen this issue posted before on cheap IO boards. Where did you get yours from?
FoxbatStargazer
Posts: 182
Joined: Thu Dec 10, 2020 5:44 pm
Has thanked: 37 times
Been thanked: 24 times

Re: Analog IO Board Color Issue

Unread post by FoxbatStargazer »

According to Sorg the I/O board VGA output is limited to 18?-bit color, it will not represent 24-bit color accurately.

He also described the ypbpr option as a "hack" so it may or may not be introducing additional issues.
C-R-T
Posts: 40
Joined: Wed Mar 03, 2021 5:10 pm
Has thanked: 8 times
Been thanked: 8 times

Re: Analog IO Board Color Issue

Unread post by C-R-T »

Try flipping the SOG switch.
User avatar
Sarge
Posts: 21
Joined: Tue Jan 12, 2021 5:26 am
Has thanked: 2 times

Re: Analog IO Board Color Issue

Unread post by Sarge »

It looks fine on my Trinitron. Hard to make out that last band, but it's still the right colors. I got my I/O board from MisterAddons.
Image
mr-box
Posts: 9
Joined: Sun May 24, 2020 8:39 pm

Re: Analog IO Board Color Issue

Unread post by mr-box »

try direct video it has better colors
d21dan
Posts: 2
Joined: Fri Apr 02, 2021 4:56 am

Re: Analog IO Board Color Issue

Unread post by d21dan »

I think the issue is the 18bit limitation so there is only six bits per channel. Direct video sounds reasonable but the only reason I’m using the analog output is to get the native 15hrz resolution which for this game which for Street fighter 2 is 384 × 224 not upscaled and the aspect ratio also be correct as in the original; otherwise I can just live with this hooked up to an LCD using HDMI running at 640x480.
mr-box
Posts: 9
Joined: Sun May 24, 2020 8:39 pm

Re: Analog IO Board Color Issue

Unread post by mr-box »

i use direct video on my crt works fine
FoxbatStargazer
Posts: 182
Joined: Thu Dec 10, 2020 5:44 pm
Has thanked: 37 times
Been thanked: 24 times

Re: Analog IO Board Color Issue

Unread post by FoxbatStargazer »

Direct Video is still 240p, the horizontal resolution gets weird (2000+) but it still appears to be an integer scale. (Ignore what the video info reports, it will say 640x480 but the scalar is actually disabled.) With that high a horizontal resolution, the TVL of your display becomes the limiting factor, so it ends up looking fine on a CRT, just like the analog output.
akeley
Posts: 264
Joined: Mon May 25, 2020 7:54 pm
Has thanked: 32 times
Been thanked: 24 times

Re: Analog IO Board Color Issue

Unread post by akeley »

There could be other factors involved, like the cable or the TV itself. Eg:
viewtopic.php?f=33&t=220
viewtopic.php?f=33&t=614
rcade
Posts: 46
Joined: Wed May 27, 2020 7:57 pm
Been thanked: 2 times

Re: Analog IO Board Color Issue

Unread post by rcade »

Wrong resistors on your analog board... but also, wait, you said component, so not RGB? This could be another issue.
User avatar
aberu
Posts: 511
Joined: Tue Jun 09, 2020 8:34 pm
Location: Longmont, CO
Has thanked: 80 times
Been thanked: 112 times

Re: Analog IO Board Color Issue

Unread post by aberu »

rcade wrote: Thu Jun 10, 2021 1:40 pm Wrong resistors on your analog board... but also, wait, you said component, so not RGB? This could be another issue.
There is not enough difference in YPbPr to account for anything this observable. YPbPr is nearly indistinguishable from RGB to the human eye.
User avatar
Sarge
Posts: 21
Joined: Tue Jan 12, 2021 5:26 am
Has thanked: 2 times

Re: Analog IO Board Color Issue

Unread post by Sarge »

Definitely something strange going on - I forgot to mention that mine was via component as well, and no issues with colors that I could see.
Image
Post Reply