X68000 beta - stopped working all of a sudden

Alkadian
Posts: 64
Joined: Thu May 28, 2020 9:55 am

Re: X68000 beta - stopped working all of a sudden

Unread post by Alkadian »

tontonkaloun wrote:
Thu Jul 16, 2020 6:36 pm
which version of quartus are you building with?
the recommended version is 17.0, if i'm not wrong
Hi,

I have got the 19.1 version for linux.
Thanks.

User avatar
tontonkaloun
Posts: 143
Joined: Sun May 24, 2020 7:38 pm

Re: X68000 beta - stopped working all of a sudden

Unread post by tontonkaloun »

Alkadian wrote:
Thu Jul 16, 2020 7:32 pm
tontonkaloun wrote:
Thu Jul 16, 2020 6:36 pm
which version of quartus are you building with?
the recommended version is 17.0, if i'm not wrong
Hi,

I have got the 19.1 version for linux.
Thanks.
try with 17.0 or 17.1 !


I have already seen compilation errors with version 19 that there is not with version 17

Alkadian
Posts: 64
Joined: Thu May 28, 2020 9:55 am

Re: X68000 beta - stopped working all of a sudden

Unread post by Alkadian »

I see, thanks. I always struggled to download the version 17 and its associated Cyclone V qdz file from the Intel site, that's why I have ended up with the 19.1. Never mind. Thanks a lot for looking at it for me.

User avatar
tontonkaloun
Posts: 143
Joined: Sun May 24, 2020 7:38 pm

Re: X68000 beta - stopped working all of a sudden

Unread post by tontonkaloun »

Alkadian wrote:
Thu Jul 16, 2020 8:00 pm
I see, thanks. I always struggled to download the version 17 and its associated Cyclone V qdz file from the Intel site, that's why I have ended up with the 19.1. Never mind. Thanks a lot for looking at it for me.

my compiled file if you want to compare with yours:
You do not have the required permissions to view the files attached to this post.

Alkadian
Posts: 64
Joined: Thu May 28, 2020 9:55 am

Re: X68000 beta - stopped working all of a sudden

Unread post by Alkadian »

tontonkaloun wrote:
Thu Jul 16, 2020 8:15 pm
Alkadian wrote:
Thu Jul 16, 2020 8:00 pm
I see, thanks. I always struggled to download the version 17 and its associated Cyclone V qdz file from the Intel site, that's why I have ended up with the 19.1. Never mind. Thanks a lot for looking at it for me.

my compiled file if you want to compare with yours:

That’s fantastic, many thanks for that!

puu
Posts: 57
Joined: Mon May 25, 2020 9:20 am
Location: Japan
Contact:

Re: X68000 beta - stopped working all of a sudden

Unread post by puu »

There is a bug in the disk emulator that seems to destroy the image when written.
I have uploaded a modified version, so please update it.
http://fpga8801.seesaa.net/article/476375530.html

Alkadian
Posts: 64
Joined: Thu May 28, 2020 9:55 am

Re: X68000 beta - stopped working all of a sudden

Unread post by Alkadian »

puu wrote:
Fri Jul 17, 2020 11:42 am
There is a bug in the disk emulator that seems to destroy the image when written.
I have uploaded a modified version, so please update it.
http://fpga8801.seesaa.net/article/476375530.html
Great, thanks for the heads up Puu!

Alkadian
Posts: 64
Joined: Thu May 28, 2020 9:55 am

Re: X68000 beta - stopped working all of a sudden

Unread post by Alkadian »

@ tontonkaloun,

When you get a chance, would you please share the new .rbf file? I have compiled it but I am receiving the same error messages as before. I would be grateful if you could do it.
Many thanks!

User avatar
tontonkaloun
Posts: 143
Joined: Sun May 24, 2020 7:38 pm

Re: X68000 beta - stopped working all of a sudden

Unread post by tontonkaloun »

Alkadian wrote:
Fri Jul 17, 2020 11:49 am
@ tontonkaloun,

When you get a chance, would you please share the new .rbf file? I have compiled it but I am receiving the same error messages as before. I would be grateful if you could do it.
Many thanks!
No problem
Gift: pc8801 core
You do not have the required permissions to view the files attached to this post.

Alkadian
Posts: 64
Joined: Thu May 28, 2020 9:55 am

Re: X68000 beta - stopped working all of a sudden

Unread post by Alkadian »

tontonkaloun wrote:
Fri Jul 17, 2020 3:42 pm
Alkadian wrote:
Fri Jul 17, 2020 11:49 am
@ tontonkaloun,

When you get a chance, would you please share the new .rbf file? I have compiled it but I am receiving the same error messages as before. I would be grateful if you could do it.
Many thanks!
No problem
Gift: pc8801 core
Hi tontonkaloun,

That was quick! Many thanks for your kind help on both cores. Really appreciated.

puu
Posts: 57
Joined: Mon May 25, 2020 9:20 am
Location: Japan
Contact:

Re: X68000 beta - stopped working all of a sudden

Unread post by puu »

Recent .qar files also include .rbf files, so please use it when compilation does not pass.
X68000/v17/output_files/release-F68kMiSTer.rbf

User avatar
wark91
Posts: 43
Joined: Sun May 24, 2020 8:34 pm

Re: X68000 beta - stopped working all of a sudden

Unread post by wark91 »

Thanks a lot to let the rdf for the one not able to build correctly !

Alkadian
Posts: 64
Joined: Thu May 28, 2020 9:55 am

Re: X68000 beta - stopped working all of a sudden

Unread post by Alkadian »

puu wrote:
Sat Jul 18, 2020 12:15 am
Recent .qar files also include .rbf files, so please use it when compilation does not pass.
X68000/v17/output_files/release-F68kMiSTer.rbf
@ puu,

That’s great, many thanks for that!

Just a request, if I may, but only when you get a chance please. It would be great if you could have a look at why Bubble Bobble freezes up when it boots up.

Thanks a lot!

Alkadian
Posts: 64
Joined: Thu May 28, 2020 9:55 am

Re: X68000 beta - stopped working all of a sudden

Unread post by Alkadian »

@ puu,

I was playing a bit with the latest revision. I have just noticed that when I play Cotton, the audio seems to play faster than expected and also after a few seconds of playing I get the error message as per the attached image. I have managed to replicate this behaviour every time I have lunched this game.

Many thanks!
You do not have the required permissions to view the files attached to this post.

User avatar
Chris23235
Posts: 119
Joined: Sun May 24, 2020 8:45 pm

Re: X68000 beta - stopped working all of a sudden

Unread post by Chris23235 »

Alkadian wrote:
Sat Jul 18, 2020 8:14 am
puu wrote:
Sat Jul 18, 2020 12:15 am
Recent .qar files also include .rbf files, so please use it when compilation does not pass.
X68000/v17/output_files/release-F68kMiSTer.rbf
@ puu,

That’s great, many thanks for that!

Just a request, if I may, but only when you get a chance please. It would be great if you could have a look at why Bubble Bobble freezes up when it boots up.

Thanks a lot!
For me it boots up fine, but freezes when I start a game.

I noticed, that the ship in Thunder Force II isn't displayed. Chase H.Q. now runs a little bit further, some of the speech on the radio screen is played before it hangs. The controls in After Burner II are non-responsive.

Alkadian
Posts: 64
Joined: Thu May 28, 2020 9:55 am

Re: X68000 beta - stopped working all of a sudden

Unread post by Alkadian »

Chris23235 wrote:
Sat Jul 18, 2020 9:55 am
Alkadian wrote:
Sat Jul 18, 2020 8:14 am
puu wrote:
Sat Jul 18, 2020 12:15 am
Recent .qar files also include .rbf files, so please use it when compilation does not pass.
X68000/v17/output_files/release-F68kMiSTer.rbf
@ puu,

That’s great, many thanks for that!

Just a request, if I may, but only when you get a chance please. It would be great if you could have a look at why Bubble Bobble freezes up when it boots up.

Thanks a lot!
For me it boots up fine, but freezes when I start a game.

I noticed, that the ship in Thunder Force II isn't displayed. Chase H.Q. now runs a little bit further, some of the speech on the radio screen is played before it hangs. The controls in After Burner II are non-responsive.
I have tried Thunder Force II and I can confirm that not only the ship but all the other enemies are not displayed at all.

puu
Posts: 57
Joined: Mon May 25, 2020 9:20 am
Location: Japan
Contact:

Re: X68000 beta - stopped working all of a sudden

Unread post by puu »

A new RTL was uploded.
This update is about priority of screens(transparent).

User avatar
wark91
Posts: 43
Joined: Sun May 24, 2020 8:34 pm

Re: X68000 beta - stopped working all of a sudden

Unread post by wark91 »

Thank you puu !

Alkadian
Posts: 64
Joined: Thu May 28, 2020 9:55 am

Re: X68000 beta - stopped working all of a sudden

Unread post by Alkadian »

puu wrote:
Wed Jul 29, 2020 1:51 am
A new RTL was uploded.
This update is about priority of screens(transparent).
That’s great. I can’t wait to give it a go!! Many thanks!!

Alkadian
Posts: 64
Joined: Thu May 28, 2020 9:55 am

Re: X68000 beta - stopped working all of a sudden

Unread post by Alkadian »

puu wrote:
Wed Jul 29, 2020 1:51 am
A new RTL was uploded.
This update is about priority of screens(transparent).
@ Puu,

Thanks again for the new release. I have finally managed to try it. Even with new version when I play the game Cotton, I keep getting the same error message as before along with the same issue with the audio which plays faster.
It plays absolutely fine with the release 20200630.
Has anybody else experienced the same issues as mine at all?
Thanks a lot!

User avatar
ron
Posts: 48
Joined: Sun May 24, 2020 7:02 pm

Re: X68000 beta - stopped working all of a sudden

Unread post by ron »

puu wrote:
Wed Jul 29, 2020 1:51 am
A new RTL was uploded.
This update is about priority of screens(transparent).
Thank You very much Púu :mrgreen: :D

johnny5
Posts: 5
Joined: Sun Jul 19, 2020 7:12 pm

Re: X68000 beta - stopped working all of a sudden

Unread post by johnny5 »

Just wondering if someone would mind uploading an .rbf of the latest release please. Thanks!

User avatar
tontonkaloun
Posts: 143
Joined: Sun May 24, 2020 7:38 pm

Re: X68000 beta - stopped working all of a sudden

Unread post by tontonkaloun »

johnny5 wrote:
Sun Aug 02, 2020 5:33 pm
Just wondering if someone would mind uploading an .rbf of the latest release please. Thanks!
You do not have the required permissions to view the files attached to this post.

johnny5
Posts: 5
Joined: Sun Jul 19, 2020 7:12 pm

Re: X68000 beta - stopped working all of a sudden

Unread post by johnny5 »

Thanks very much!

Shaneus
Posts: 8
Joined: Mon May 25, 2020 6:56 am

Re: X68000 beta - stopped working all of a sudden

Unread post by Shaneus »

Does this still require the I/O board and/or a second microSD card for disk storage? Or will it use a VHD?

Post Reply