mt32-pi not Booting on Model 3 A+ board; Shows "Power Failure Type B" Blink Pattern [Solved]

BigDanG
Posts: 3
Joined: Sat Nov 18, 2023 8:35 am
Has thanked: 2 times
Been thanked: 6 times

mt32-pi not Booting on Model 3 A+ board; Shows "Power Failure Type B" Blink Pattern [Solved]

Unread post by BigDanG »

This was originally going to be a request for help, but in the effort of collecting information for my issue, I was able to find a solution.

Problem

I got a misterfpga.co.uk mt32-pi hat, a Raspberry Pi 3 Model A+ board, and a Geekworm enclosure. I prepared my SD card, both via guiformat in Windows and (when that didn't work) using the mt32pi_installer.sh script. But with each preparation method, every time I tried to turn it on, the OLED panel didn't turn on and show the boot screen. Instead the Green ACT LED blinked in a 4 long, 7 short pattern, indicating with "Power Failure Type B".

Solution

I was at wits-end trying to find a solution by scouring all the support posts here. But in preparing my post I stumbled on this thread indicating that new RPi 3 board revisions need new firmware, which is not present in some OS distros.

Because I have a Revision 2 Model A+ PCB, I needed firmware as recent as April 2023 as indicated on the PCN. Since the latest release was prepared in March 2023, my firmware was out of date. So, I updated the firmware from the latest release, following the instructions here: https://pip.raspberrypi.com/categories/ ... rmware.pdf.

For mt32-pi, this meant downloading https://github.com/raspberrypi/firmware ... stable.zip, and copying files from the latest firmware's boot directory over the corresponding files in the root directory of the SD card:

  • fixup_cd.dat
  • fixup4cd.dat
  • start_cd.elf
  • start4cd.elf

Once I did that (as well as the other manual steps of adding the ROMs and SoundFonts), the unit booted with the OLED panel showing the splash screen just as expected once plugged into my User port.

Unfortunately, I can't add an issue to the GitHub to requesting a firmware update in a new release, but anyone else with a new Raspberry Pi 3 board revision can also manually update their firmware as a workaround for the time being.

FPGA64
Top Contributor
Posts: 807
Joined: Mon Mar 01, 2021 3:10 pm
Has thanked: 46 times
Been thanked: 340 times

Re: mt32-pi not Booting on Model 3 A+ board; Shows "Power Failure Type B" Blink Pattern [Solved]

Unread post by FPGA64 »

Thanks for the detailed explanation. It will be a good resource for anyone with a newer Raspberry Pi and Mt32

mubert
Posts: 10
Joined: Thu Jan 18, 2024 12:44 pm
Has thanked: 2 times
Been thanked: 2 times

Re: mt32-pi not Booting on Model 3 A+ board; Shows "Power Failure Type B" Blink Pattern [Solved]

Unread post by mubert »

BigDanG, thank you x100! I was tearing my hair out trying to understand what was going wrong. I recently bought a new Pi 3 A+ and was experiencing the same or similar issue - no OLED screen, no response from USB MIDI input. The LED lights would turn on, and I saw activity on green but it looked like random read activity to me, so I ignored it (perhaps it was the same pattern and I missed it).

I went through the trouble of compiling MT32-pi with the HDMI debug console output enabled because every Github Actions deployment of that build is "expired" and unavailable for download. Spoiler: that didn't help. Even with a debug-enabled kernel8.img, there was no HDMI signal. The failure occurs earlier in the boot process.

Anyway, replacing those files fixed it. Thank you again for posting this.

HardDrive
Posts: 1
Joined: Sat Mar 23, 2024 11:46 am
Has thanked: 1 time

Re: mt32-pi not Booting on Model 3 A+ board; Shows "Power Failure Type B" Blink Pattern [Solved]

Unread post by HardDrive »

Not part of the FPGA community, but wanted to post a thank-you to OP.

I'm trying to set up a system with MotionEyeOS, using a freshly bought Raspberry Pi 3 A+ and ran right into this problem. This post put me onto the track if it being a firmware issue (the last release of MotionEyeOS was in 2020). Grabbing the updated firmware and replacing start.elf and fixup.dat worked like a charm.

So, thank you and good luck with your projects :)

MrXax
Posts: 1
Joined: Thu Apr 18, 2024 10:17 pm
Has thanked: 1 time

Re: mt32-pi not Booting on Model 3 A+ board; Shows "Power Failure Type B" Blink Pattern [Solved]

Unread post by MrXax »

Thank you, thank you, thank you!

I'm so glad that I found this post. Everything else I was reading was about checking the USB cable, checking PINs and jumpers... but it was this post that fixed the problem for me.

vfxsup
Posts: 1
Joined: Thu Jun 06, 2024 7:33 am

Re: mt32-pi not Booting on Model 3 A+ board; Shows "Power Failure Type B" Blink Pattern [Solved]

Unread post by vfxsup »

Thank you very much for posting this, I've been trying to debug this problem for hours and your solution finally worked.

Post Reply