DaemonBite Adding Lag [Solved]

Discussion of keyboards, gamepads, joysticks and other input related peripherals.
kernelchagi
Posts: 6
Joined: Mon Dec 13, 2021 12:16 pm
Been thanked: 1 time

DaemonBite Adding Lag [Solved]

Unread post by kernelchagi »

Hello. Im trying out daemonbite for 2 players for my cabinet.

I compiled the code from here https://github.com/MickGyver/DaemonBite-Arcade-Encoder and i compiled and flashed into 2 arduinos pro micro without touching anything in the code.

After making all the wiring and try them out i realize that they are adding quite a lot of lag. I dont have the tools to make a formal test but im 100% sure that they add lag because one test that i do with the bridges of the nes version of contra.

Any ideas? What did i make wrong?
kernelchagi
Posts: 6
Joined: Mon Dec 13, 2021 12:16 pm
Been thanked: 1 time

Re: DaemonBite Adding Lag

Unread post by kernelchagi »

Dont know if it is helping but i have 2 daemonbite at the same time and i have the u-boot.exe with this line:
v=loglevel=4 usbhid.jspoll=1 xpad.cpoll=1
thorr
Posts: 663
Joined: Mon Jul 06, 2020 9:37 pm
Has thanked: 272 times
Been thanked: 129 times

Re: DaemonBite Adding Lag

Unread post by thorr »

Try just one direct into the MiSTer without a USB hub. Maybe the hub you are using is adding lag. Just a guess.
caad
Posts: 81
Joined: Sun Oct 03, 2021 4:37 pm
Has thanked: 2 times
Been thanked: 19 times

Re: DaemonBite Adding Lag

Unread post by caad »

Maybe the game is doing debouncing internally, in a way that adds lag.. the problem with Daemonbite is that debouncing isn't enabled by default. You can set this to 1 in the code before you compile/upload it. Try it out.
kernelchagi
Posts: 6
Joined: Mon Dec 13, 2021 12:16 pm
Been thanked: 1 time

Re: DaemonBite Adding Lag

Unread post by kernelchagi »

caad wrote: Mon Dec 13, 2021 3:40 pm Maybe the game is doing debouncing internally, in a way that adds lag.. the problem with Daemonbite is that debouncing isn't enabled by default. You can set this to 1 in the code before you compile/upload it. Try it out.
I just tryed with debouncing enabled in the code of the daemonbite, it feels exactly the same to me. I tryed also with the fast_polling script on and off, and also with that line code in the u-boot and without, always feels the same. I have the problem when i connect only one daemonbite or both, it doesnt matter. I tryed the game "Gigawing" with my stick with a brook universal fighting board and it feels way more responsive. I dont know what else to try, im just out of ideas.
kernelchagi
Posts: 6
Joined: Mon Dec 13, 2021 12:16 pm
Been thanked: 1 time

Re: DaemonBite Adding Lag

Unread post by kernelchagi »

thorr wrote: Mon Dec 13, 2021 3:05 pm Try just one direct into the MiSTer without a USB hub. Maybe the hub you are using is adding lag. Just a guess.
I dont think since my universal fighting board is working flawlessly using the same hub and with the daemonbite plugged at the same time.
thorr
Posts: 663
Joined: Mon Jul 06, 2020 9:37 pm
Has thanked: 272 times
Been thanked: 129 times

Re: DaemonBite Adding Lag

Unread post by thorr »

You could try plugging it into a Windows PC and bring up the gamepad test utility to see when you move it and press buttons if there is any significant delay on the screen.
kernelchagi
Posts: 6
Joined: Mon Dec 13, 2021 12:16 pm
Been thanked: 1 time

Re: DaemonBite Adding Lag

Unread post by kernelchagi »

thorr wrote: Wed Dec 15, 2021 11:26 pm You could try plugging it into a Windows PC and bring up the gamepad test utility to see when you move it and press buttons if there is any significant delay on the screen.
Going to try that, i also got another arduino board, because im thinking it could be that i got a very cheap ones...
kernelchagi
Posts: 6
Joined: Mon Dec 13, 2021 12:16 pm
Been thanked: 1 time

Re: DaemonBite Adding Lag

Unread post by kernelchagi »

Ok, solved. I had the mouse: emu/sniper mapped and that was causing the issue.
Got the answer here: viewtopic.php?f=32&t=2657&p=26610&hilit ... uck#p26610
I was not believing that i was the only one with this issue! haha
thorr
Posts: 663
Joined: Mon Jul 06, 2020 9:37 pm
Has thanked: 272 times
Been thanked: 129 times

Re: DaemonBite Adding Lag [Solved]

Unread post by thorr »

Glad you got it working!
Post Reply